Обновился с Sarge до Etch: SANE вновь сканирует от рута

Собственно, это даже не косяк при обновлении, а некоторая невнимательность поддерживающих пакеты sane, и всё-таки. В своё время я писал о том, как в Дебиане обходится проблема со сканированием от рута - нужно включить пользователя в группу scanner, и в GiMP появится возможность сканировать и от обычного пользователя.

При обновлении до Этч зависимости потянули обновляться и sane, но его библиотеки остались старых версий. Поэтому, запустив новенький GiMP, я был очень удивлён отсутствию у меня возможности сканировать. От рута сканировать можно, а простому смертному - нет. Ещё раз проверил, набрав

$ groups
и получил правильный ответ:
penta4 dialout cdrom floppy audio video plugdev scanner vboxusers
Хм... кто виноват, и что делать? (с) классика
Гугление не помогло, зато помогла смекалка: надо просто удалить старые пакеты sane, старые библиотеки (почему, интересно, они не удалились мудрым aptitude по зависимостям?) и поставить их снова.
aptitude remove sane xsane libsane libsane-extras

aptitude install sane xsane libsane libsane-extras xsane-common

После этого всё сразу заиграло и запело: сканер появился, опознался и заработал, весело подмигивая лампочками. К слову, обработка полученного со сканера изображения SANE-ом стала намного быстрее, что не может не радовать.

Резюме: при обновлении с Debian Sarge до Etch сносим пакеты сканера и ставим новые, не забывая поставить новые и конфиги sane.

4 комментариев: |высказаться!| RSS-лента дискуссии.|
Анонимный комментирует...

Если не секрет, что за сканер?
Я всё страдаю от того, что мой Benq 5550T не поддерживается.

DimkaS

virens комментирует...

2 DimkaS
Если не секрет, что за сканер?
Epson Perfection 2400, в Линукс работает превосходно.

Я всё страдаю от того, что мой Benq 5550T не поддерживается.
SANE не обещает изменение положения?

a2l комментирует...

Хм... кто виноват, и что делать? (с) классика
Гугление не помогло, зато помогла смекалка: надо просто удалить старые пакеты sane, старые библиотеки (почему, интересно, они не удалились мудрым aptitude по зависимостям?) и поставить их снова.

Хех, aptitude что сказано, то и делает, что не сказано не делает -- " не надо нам dist-upgrade..." Раз не надо - чего к aptitude придираться? А?
Повторюсь: Читайте документацию - она рулез! Может заоодно и гуглевским серверам полегчает :-)

virens комментирует...

2 a2l пишет...
Повторюсь: Читайте документацию - она рулез! Может заоодно и гуглевским серверам полегчает :-)
Документация конкретно на SANE просто ужасна, так что не надо перегибать палку. Читать документацию я умею, но догадываться о том, чего не сказал разработчик - это слишком. Мейнтейнер пакета мог бы потребовать зависимостей в SANE от новых библиотек, но не сделал этого.

Отправить комментарий

Подписаться на RSS-ленту комментариев к этому посту.